Python疑难杂症

python-gssapi 安装失败

排除网速原因, 可能是缺少库

# Centos:
yum install krb5-devel

# Debian:
apt install libkrb5-dev

Gevent安装ValueError的错误

If you see ValueError: ("Expected ',' or end-of-list in", "cffi >= 1.11.5 ; sys_platform == 'win32' and platform_python_implementation == 'CPython'", 'at', " ; sys_platform == 'win32' and platform_python_implementation == 'CPython'"), the version of setuptools is too old. Install a more recent version of setuptools.

# 更新setuptools即可
sudo pip install setuptools --upgrade

gevent monkey

AttributeError: module 'select' has no attribute 'error'

monkey.patch_all(select=False)

本文链接:

https://www.lzskyline.com/archives/77/
1 + 3 =
快来做第一个评论的人吧~